Brynhildr

KeroRemote

リモートデスクトップエンジニアのブログ。

Brynhildr「2.5.7」リリース

かなり久々のバージョンアップです。

まず、Windows Server 2016とWindows Server 2019に対応しました。それに伴いまして動作上の仕様を変更しました。安定性とか機敏性がやや向上してるはずです。あくまでも「やや」レベルですけど。実はこの新しいサーバーOSに対応した件で新しい仕組みが1つ入ってまして、ちょっと心配っちゃ心配なんですけど、もしうまく動作するのであれば結構暫くいけるんじゃないかと思う仕組みだったりします。もし「ダメだー!」的なご報告がありましたら即座にバージョンアップしても元の仕組みに戻しますんでその時はごめんなさい。

次に、ログ出力周りの仕様を変更しました。シャットダウンがログに出るようにしました。でも、シャットダウン時にOSが早めにBrynhildrのプロセスを終わらせちゃってシャットダウンがログに出ない時もありますんでその時はごめんなさい。

あと、微調整がところどころに入っておりやす。

以上でございます。

Brynhildr Download




4件のコメント ... ( 管理人承認制 )



server側windows10 pro 64 coreM-5Y51。client側windows10 Home 64 corei7-4510u、どちらもノートです。ダウンロードされたフォルダの置き(展開)場所も、C:¥257brynhildrとやり直してみましたが(これも誤り?!)し。あとデフォルトのポート番号55500ばかりでなく、netstatで他の開いてそうなポート番号も試してみましたが‥。とにかくconnection failed0×11420….とか、create failed‥server側、client側に様々エラーとなり、繋がりません。(server側でエラーとならなかった時にプロンプトでTIME_WAITとなるのかな?!とも思い)、その時点ですぐさまclient側で設定してみるのですがやはり同じです。いったいどうすればよいのでしょう??そもそも私のようなレベルの者では手を出すべき対象ではないんですかね。何とかご教授頂けましたらありがたく存じます。


匿名  2019/04/17


> create failed


サーバー側の方が正常に起動できていないのであれば、まずサーバー側を正常に稼働させる必要があるかと思います。「create failed」とサーバー側でエラーになるようですが、こちらの後ろのエラーコード(0×00000形式)は何になっていますでしょうか?


エラーがでないのであればファイアウォールの可能性もあるかと思いましたが、指定したTCPポートが使えていない可能性がありましたので、そうしますと他のアプリが指定したTCPポートを既に利用しているか、もしくはセキュリティソフト(もしくはウイルス・・・)などでTCPポートを利用できなくなっているといった可能性も考えられると思います。ですのでその辺をご確認頂ければと思います。よろしくお願いいたします。


IchiGeki  2019/04/18


ご丁寧なコメント有り難うございます。
まずファイアーウォールは解除されているか確認してから行うようにしています。
拙いながらTCPポートの選択設定の仕方を説明したサイトを見つけましたので、55500を指定してやり直してみました。windowsdefender(双方)やセキュリティソフト(クライアント側)も無効化してやってます。
今日も今日とてやってるのですが‥。
サーバー側は管理者権限でも、そのままでも、どちらも一貫して「Sarver Setup failed (0×07402)」というエラーコードが、
クライアント側は、サーバー側が繋がってないのでしょうからそもそも繋ごうとする事じたい誤りなのでしょうけれど。こちらは専ら「Connection Failed (0×11420)」のエラーコードです。ちなみに、サーバー側を何度かアンインストールも含め、何度も何度もやり直してる途上で、Serviceの項目にDeleteが一度表示されてから、Createとなるのでやってみるのですが‥依然として繋がりません。


ウイルス駆除ソフトなど走らせてみてから、改めてやり直した方がいいのでしょうか?!


dhstyle  2019/04/18


> Connection Failed (0×11420)


こちらのエラーですとやはり指定したTCPポートが利用できない(待ち受けができない)ということになります。そもそも通信が利用できない状況ですのでWindowsサービスと起動させても結果は同じかと思います。


netstatで確認されているかと思いますが利用されていない例えば40000番や60000番もお試し頂ければと思います。理論的には1-65535までが指定は可能ですので。(使ってはいけないのも多数ありますが)


WindowsDefenderが動作している環境で仮にウリスに感染しているとなると新種ウイルスの可能性が高く、駆除ソフトでも検知できない可能性があると思います。前にそういうケースに遭遇したことがありまして。


とりあえず通信系の何が原因なのかを特定する旨も含めまして、別ユーザーで試してみることとか、他のマシンでも同様の現象が発生しないか、なども併せてご確認頂ければと思います。よろしくお願いいたします。


IchiGeki  2019/04/18




... 不具合報告の際は、アプリのバージョンやOS等の動作環境の記載を御願い致します。

表記されている会社名・製品名・システム名などは、各社の商標、または登録商標です。
当サイトはAmazon.co.jpアソシエイトプログラムに参加しています。
© 2010 IchiGeki